/[public]/qemu-start/trunk/debian/rules
ViewVC logotype

Annotation of /qemu-start/trunk/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 290 - (hide annotations)
Sat Feb 11 16:27:15 2006 UTC (18 years, 2 months ago) by frodo
File size: 1956 byte(s)
Imported sources

1 frodo 290 #!/usr/bin/make -f
2     # -*- makefile -*-
3     # Sample debian/rules that uses debhelper.
4     # This file was originally written by Joey Hess and Craig Small.
5     # As a special exception, when this file is copied by dh-make into a
6     # dh-make output file, you may use that output file without restriction.
7     # This special exception was added by Craig Small in version 0.37 of dh-make.
8    
9     # Uncomment this to turn on verbose mode.
10     #export DH_VERBOSE=1
11    
12    
13    
14    
15     CFLAGS = -Wall -g
16    
17     ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18     CFLAGS += -O0
19     else
20     CFLAGS += -O2
21     endif
22    
23     configure: configure-stamp
24     configure-stamp:
25     dh_testdir
26     # Add here commands to configure the package.
27    
28     touch configure-stamp
29    
30    
31     build: build-stamp
32    
33     build-stamp: configure-stamp
34     dh_testdir
35    
36     # Add here commands to compile the package.
37     $(MAKE)
38     #docbook-to-man debian/qemu-start.sgml > qemu-start.1
39    
40     touch build-stamp
41    
42     clean:
43     dh_testdir
44     dh_testroot
45     rm -f build-stamp configure-stamp
46    
47     # Add here commands to clean up after the build process.
48     -$(MAKE) clean
49    
50     dh_clean
51    
52     install: build
53     dh_testdir
54     dh_testroot
55     dh_clean -k
56     dh_installdirs
57    
58     # Add here commands to install the package into debian/qemu-start.
59     install -o root -g root -m 710 qemu-start $(CURDIR)/debian/qemu-start/usr/bin/
60    
61    
62     # Build architecture-independent files here.
63     binary-indep: build install
64     # We have nothing to do by default.
65    
66     # Build architecture-dependent files here.
67     binary-arch: build install
68     dh_testdir
69     dh_testroot
70     dh_installchangelogs
71     dh_installdocs
72     # dh_installexamples
73     # dh_install
74     # dh_installmenu
75     # dh_installdebconf
76     # dh_installlogrotate
77     # dh_installemacsen
78     # dh_installpam
79     # dh_installmime
80     # dh_installinit
81     # dh_installcron
82     # dh_installinfo
83     dh_installman
84     dh_link
85     dh_strip
86     dh_compress
87     dh_fixperms
88     # dh_perl
89     # dh_python
90     # dh_makeshlibs
91     dh_installdeb
92     dh_shlibdeps
93     dh_gencontrol
94     dh_md5sums
95     dh_builddeb
96    
97     binary: binary-indep binary-arch
98     .PHONY: build clean binary-indep binary-arch binary install configure

Properties

Name Value
svn:executable *

frodo@frodo.looijaard.name
ViewVC Help
Powered by ViewVC 1.1.26