/[public]/psiconv/trunk/debian/rules
ViewVC logotype

Contents of /psiconv/trunk/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 214 - (show annotations)
Sat Feb 21 12:10:04 2004 UTC (20 years, 1 month ago) by frodo
File size: 2996 byte(s)
(Frodo) Debian stuff
  * Changed psiconv-dev to libpsiconv-dev
  * Bumped up the version number

1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Uncomment this to turn on verbose mode.
4 #export DH_VERBOSE=1
5
6
7 # These are used for cross-compiling and for saving the configure script
8 # from having to guess our platform (since we know it already)
9 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
10 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
11
12
13 CFLAGS = -Wall -g
14
15 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
16 CFLAGS += -O0
17 else
18 CFLAGS += -O2
19 endif
20 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
21 INSTALL_PROGRAM += -s
22 endif
23
24 config.status: configure
25 dh_testdir
26 CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --enable-ascii-docs --datadir=/usr/share/doc --mandir=/usr/share/man --with-etcdir=/etc/psiconv
27
28
29 build: build-stamp
30 build-stamp: config.status
31 dh_testdir
32 $(MAKE) pkgdatadir=/usr/share/doc/libpsiconv6
33 touch build-stamp
34
35 clean:
36 dh_testdir
37 dh_testroot
38 rm -f build-stamp
39 -$(MAKE) distclean
40 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
41 cp -f /usr/share/misc/config.sub config.sub
42 endif
43 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
44 cp -f /usr/share/misc/config.guess config.guess
45 endif
46 dh_clean
47
48 install: build
49 dh_testdir
50 dh_testroot
51 dh_clean -k
52 $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp pkgdatadir=/usr/share/doc/libpsiconv6
53
54
55 # Build architecture-independent files here.
56 binary-indep: build install psiconv-doc
57
58
59 # Build architecture-dependent files here.
60 binary-arch: build install libpsiconv-dev libpsiconv6 psiconv
61
62 libpsiconv-dev:
63 dh_testdir
64 dh_testroot
65 rm -rf debian/$@
66 dh_installdirs -p $@
67 ln -sfn libpsiconv6 debian/$@/usr/share/doc/$@
68 dh_install -p $@ --sourcedir debian/tmp
69 dh_installman -p $@
70 dh_link -p $@
71 dh_strip -p $@
72 dh_compress -p $@
73 dh_fixperms -p $@
74 dh_installdeb -p $@
75 dh_gencontrol -p $@
76 dh_md5sums -p $@
77 dh_builddeb -p $@
78
79 psiconv-doc:
80 dh_testdir
81 dh_testroot
82 rm -rf debian/$@
83 dh_installdirs -p $@
84 ln -sfn libpsiconv6 debian/$@/usr/share/doc/$@
85 dh_install -p $@ --sourcedir debian/tmp
86 dh_compress -p $@
87 dh_fixperms -p $@
88 dh_installdeb -p $@
89 dh_gencontrol -p $@
90 dh_md5sums -p $@
91 dh_builddeb -p $@
92
93 libpsiconv6:
94 dh_testdir
95 dh_testroot
96 rm -rf debian/$@
97 dh_installdirs -p $@
98 dh_installdocs -p $@
99 dh_install -p $@ --sourcedir debian/tmp
100 dh_installchangelogs -p $@
101 dh_link -p $@
102 dh_strip -p $@
103 dh_compress -p $@
104 dh_fixperms -p $@
105 dh_makeshlibs -p $@
106 dh_shlibdeps -p $@
107 dh_installdeb -p $@
108 dh_gencontrol -p $@
109 dh_md5sums -p $@
110 dh_builddeb -p $@
111
112 psiconv:
113 dh_testdir
114 dh_testroot
115 rm -rf debian/$@
116 dh_installdirs -p $@
117 ln -sfn libpsiconv6 debian/$@/usr/share/doc/$@
118 dh_install -p $@ --sourcedir debian/tmp
119 dh_installman -p $@
120 dh_link -p $@
121 dh_strip -p $@
122 dh_compress -p $@
123 dh_fixperms -p $@
124 dh_shlibdeps -p $@
125 dh_installdeb -p $@
126 dh_gencontrol -p $@
127 dh_md5sums -p $@
128 dh_builddeb -p $@
129
130
131 binary: binary-indep binary-arch
132 .PHONY: build clean binary-indep binary-arch binary install

Properties

Name Value
svn:executable *

frodo@frodo.looijaard.name
ViewVC Help
Powered by ViewVC 1.1.26